最新公告
  • 欢迎您光临51分享吧,本站秉承服务宗旨 履行“站长”责任,销售只是起点 服务永无止境!立即加入我们
  • 五种图片灰度处理算法

    .版本 2
    .支持库 BmpOperate
    
    .子程序 灰度处理_移位算法, 字节集, , 移位算法
    .参数 图片, 字节集
    .局部变量 位图, 位图
    .局部变量 x, 整数型
    .局部变量 y, 整数型
    .局部变量 RGB, 字节集
    .局部变量 颜色值, 整数型
    
    位图.载入数据 (图片)
    .计次循环首 (位图.取高度 (), y)
        .计次循环首 (位图.取宽度 (), x)
            RGB = 到字节集 (位图.取某点颜色 (x - 1, y - 1))
            颜色值 = 右移 (RGB [1] × 28 + RGB [2] × 151 + RGB [3] × 77, 8)
            位图.置某点颜色 (x - 1, y - 1, 取颜色值 (颜色值, 颜色值, 颜色值))
        .计次循环尾 ()
    .计次循环尾 ()
    返回 (位图.取位图数据 ())
    
    .子程序 灰度处理_整数算法, 字节集, , 整数算法
    .参数 图片, 字节集
    .局部变量 位图, 位图
    .局部变量 x, 整数型
    .局部变量 y, 整数型
    .局部变量 RGB, 字节集
    .局部变量 颜色值, 整数型
    
    位图.载入数据 (图片)
    .计次循环首 (位图.取高度 (), y)
        .计次循环首 (位图.取宽度 (), x)
            RGB = 到字节集 (位图.取某点颜色 (x - 1, y - 1))
            颜色值 = (RGB [1] × 30 + RGB [2] × 59 + RGB [3] × 11) ÷ 100
            位图.置某点颜色 (x - 1, y - 1, 取颜色值 (颜色值, 颜色值, 颜色值))
        .计次循环尾 ()
    .计次循环尾 ()
    返回 (位图.取位图数据 ())
    
    .子程序 灰度处理_浮点算法, 字节集, , 浮点算法
    .参数 图片, 字节集
    .局部变量 位图, 位图
    .局部变量 x, 整数型
    .局部变量 y, 整数型
    .局部变量 RGB, 字节集
    .局部变量 颜色值, 整数型
    
    位图.载入数据 (图片)
    .计次循环首 (位图.取高度 (), y)
        .计次循环首 (位图.取宽度 (), x)
            RGB = 到字节集 (位图.取某点颜色 (x - 1, y - 1))
            颜色值 = RGB [1] × 0.3 + RGB [2] × 0.59 + RGB [3] × 0.11
            位图.置某点颜色 (x - 1, y - 1, 取颜色值 (颜色值, 颜色值, 颜色值))
        .计次循环尾 ()
    .计次循环尾 ()
    返回 (位图.取位图数据 ())
    
    .子程序 灰度处理_仅取绿色, 字节集, , 仅取绿色
    .参数 图片, 字节集
    .局部变量 位图, 位图
    .局部变量 x, 整数型
    .局部变量 y, 整数型
    .局部变量 RGB, 字节集
    .局部变量 颜色值, 整数型
    
    位图.载入数据 (图片)
    .计次循环首 (位图.取高度 (), y)
        .计次循环首 (位图.取宽度 (), x)
            RGB = 到字节集 (位图.取某点颜色 (x - 1, y - 1))
            颜色值 = RGB [2]
            位图.置某点颜色 (x - 1, y - 1, 取颜色值 (颜色值, 颜色值, 颜色值))
        .计次循环尾 ()
    .计次循环尾 ()
    返回 (位图.取位图数据 ())
    
    .子程序 灰度处理_平均值法, 字节集, , 平均值法
    .参数 图片, 字节集
    .局部变量 位图, 位图
    .局部变量 x, 整数型
    .局部变量 y, 整数型
    .局部变量 RGB, 字节集
    .局部变量 颜色值, 整数型
    
    位图.载入数据 (图片)
    .计次循环首 (位图.取高度 (), y)
        .计次循环首 (位图.取宽度 (), x)
            RGB = 到字节集 (位图.取某点颜色 (x - 1, y - 1))
            颜色值 = (RGB [1] + RGB [2] + RGB [3]) ÷ 3
            位图.置某点颜色 (x - 1, y - 1, 取颜色值 (颜色值, 颜色值, 颜色值))
        .计次循环尾 ()
    .计次循环尾 ()
    返回 (位图.取位图数据 ())

    @糖心疼

    文件下载

    解压密码:
    下载地址

    本站大部分下载资源收集于网络,只做学习和交流使用,版权归原作者所有,若为付费资源,请在下载后24小时之内自觉删除,若作商业用途,请到原网站购买,由于未及时购买和付费发生的侵权行为,与本站无关。本站发布的内容若侵犯到您的权益,请联系本站删除,我们将及时处理!
    51分享吧 » 五种图片灰度处理算法
    • 180会员总数(位)
    • 2014资源总数(个)
    • 0本周发布(个)
    • 0 今日发布(个)
    • 336稳定运行(天)

    51分享吧 51DZSC.COM

    开通VIP 超级项目
    升级SVIP尊享更多特权立即升级