最新公告
  • 欢迎您光临51分享吧,本站秉承服务宗旨 履行“站长”责任,销售只是起点 服务永无止境!立即加入我们
  • 纯算法实现\u编码转中文

    .版本 2
    
    .程序集 程序集2
    
    .子程序 Usc2ToGB2312, 字节集, 公开
    .参数 Data, 字节集, , u
    .局部变量 pos, 整数型
    .局部变量 spos, 整数型
    .局部变量 hex_bin, 字节集
    .局部变量 uni_bin, 字节集
    
    .如果真 (Data = {  })
        返回 ({  })
    .如果真结束
    spos = 1
    .循环判断首 ()
        pos = 寻找字节集 (Data, { 92, 117 }, spos)
        .如果真 (pos ≠ -1)
            hex_bin = 取字节集中间 (Data, pos + 2, 4)
            uni_bin = _Hex2Uni (hex_bin)
            .如果真 (uni_bin ≠ {  })
                Data = 子字节集替换 (Data, { 92, 117 } + hex_bin, uni_bin, pos, )
            .如果真结束
            spos = pos + 2
        .如果真结束
        处理事件 ()
    .循环判断尾 (pos ≠ -1)
    
    返回 (Data)
    
    .子程序 _Usc2Ansi, 字节集, , ' 本源码来自三叶资源网(www.sanye.cx)
    .参数 Unicode_bin, 字节集
    .局部变量 resBin, 字节集
    
    resBin = 取空白字节集 (2)' 本源码来自三叶资源网(www.sanye.cx)
    WideCharToMultiByte_ (936, 512, Unicode_bin, -1, resBin, 2, 0, 假)
    返回 (resBin)
    
    .子程序 _Hex2Dec_ASM, 整数型, , 进制_十六到十,作者混沌(QQ 1339307648)
    .参数 十六进制, 文本型
    
    
    置入代码 ({ 49, 192, 139, 93, 8, 139, 27, 133, 219, 116, 55, 49, 210, 138, 19, 67, 128, 250, 57, 119, 10, 128, 250, 48, 114, 5, 128, 234, 48, 235, 28, 128, 250, 70, 119, 10, 128, 250, 65, 114, 5, 128, 234, 55, 235, 13, 128, 250, 102, 119, 15, 128, 250, 97, 114, 10, 128, 234, 87, 193, 224, 4, 1, 208, 235, 203, 93, 194, 4, 0 })
    返回 (0)
    
    .子程序 _Hex2Uni, 字节集
    .参数 hex_bin, 字节集
    .局部变量 ihex, 整数型
    .局部变量 low, 整数型
    .局部变量 high, 整数型
    
    .如果真 (取字节集长度 (hex_bin) ≠ 4)
        返回 ({  })
    .如果真结束
    ihex = _Hex2Dec_ASM (到文本 (hex_bin))
    .判断开始 (ihex > 19967 且 ihex < 40908 或 ihex > 65279 且 ihex < 65520)
        low = 右移 (位与 (ihex, 65280), 8)
        high = 位与 (ihex, 255)
        返回 (_Usc2Ansi (到字节集 (到字节 (high)) + 到字节集 (到字节 (low))))
    .默认
        返回 ({  })
    .判断结束

    @Casyo

    文件下载

    解压密码:
    下载地址

    本站大部分下载资源收集于网络,只做学习和交流使用,版权归原作者所有,若为付费资源,请在下载后24小时之内自觉删除,若作商业用途,请到原网站购买,由于未及时购买和付费发生的侵权行为,与本站无关。本站发布的内容若侵犯到您的权益,请联系本站删除,我们将及时处理!
    51分享吧 » 纯算法实现\u编码转中文
    • 182会员总数(位)
    • 2014资源总数(个)
    • 0本周发布(个)
    • 0 今日发布(个)
    • 341稳定运行(天)

    51分享吧 51DZSC.COM

    开通VIP 超级项目
    升级SVIP尊享更多特权立即升级