最新公告
  • 欢迎您光临51分享吧,本站秉承服务宗旨 履行“站长”责任,销售只是起点 服务永无止境!立即加入我们
  • 当当网登录cookie处理例子

    一个简单的Cookie处理,js里生成

    @nliger2015

    .版本 2
    .支持库 EThread
    .支持库 spec
    
    .程序集 窗口程序集_启动窗口, , , ' 本源码来自三叶资源网(www.sanye.cx)
    .程序集变量 点击次数, 整数型
    .程序集变量 倒字验证码坐标, 文本型
    
    .子程序 __启动窗口_创建完毕, , , ' 本源码来自三叶资源网(www.sanye.cx)
    
    启动线程 (&子程序1, , )
    ' 本源码来自三叶资源网(www.sanye.cx)
    
    .子程序 _登录按钮_被单击
    
    登录按钮.禁止 = 真
    
    .子程序 子程序1, , , ' 本源码来自三叶资源网(www.sanye.cx)
    .局部变量 user, 文本型
    .局部变量 pwd, 文本型
    .局部变量 js, JScript
    .局部变量 http, WinHttp
    .局部变量 result, 文本型
    .局部变量 cookie, 文本型
    .局部变量 __permanent_id, 文本型
    .局部变量 login_dangdang_com, 文本型
    
    user = “17081100052”
    pwd = “a667789a”  ' 本源码来自三叶资源网(www.sanye.cx)
    js.ExecuteStatement (#__permanent_id)
    __permanent_id = js.Run_Str (“createPermanentID”)
    调试输出 (__permanent_id)
    ' t = js.Run_Str (“getTimes”) 13位现行时间戳
    http.Open (“GET”, “https://login.dangdang.com/login_core.php?&t=” + js.Run_Str (“getTimes”) + “&jsoncallback=?”)
    http.Send ()
    cookie = Cookie合并更新 (“__permanent_id=” + __permanent_id, http.GetResponseCookies ())
    调试输出 (cookie)
    ' 本源码来自三叶资源网(www.sanye.cx)
    http.Open (“GET”, “https://captcha.dangdang.com/show.php?t=” + js.Run_Str (“getTimes”))
    http.SetCookie (cookie)
    http.Send ()
    login_dangdang_com = http.GetResponseCookies ()
    调试输出 (login_dangdang_com)
    验证码图片框.图片 = http.GetResponseBody ()
    .循环判断首 ()
        延时 (100)
    .循环判断尾 (登录按钮.禁止 = 假)
    http.Open (“GET”, “https://login.dangdang.com/p/emailandmobile_check.php?usermobile=” + user + “&t=” + js.Run_Str (“getTimes”) + “&jsoncallback=jsonp” + js.Run_Str (“getTimes”))
    http.SetCookie (cookie)
    http.Send ()
    result = http.GetResponseText2 ()
    cookie = Cookie合并更新 (cookie, http.GetResponseCookies ()) + “ ” + login_dangdang_com
    调试输出 (result, cookie)
    ' 本源码来自三叶资源网(www.sanye.cx)
    http.Open (“GET”, “https://login.dangdang.com/login_core_do.php?&jsoncallback=jsonp” + js.Run_Str (“getTimes”) + “&_=” + js.Run_Str (“getTimes”) + “&&request_from=1&username=” + user + “&password=” + pwd + “&login_type=1&captcha_code=” + 倒字验证码坐标 + “&is_persist=on&sms_vcode=&verify_type=8&order_pid=&t=” + js.Run_Str (“getTimes”))
    http.SetCookie (cookie)
    http.Send ()
    result = http.GetResponseText2 ()
    调试输出 (result, http.GetResponseCookies ())
    ' 开始运行被调试程序
    ' * “20170113013331393167295636071360687”
    ' * “__permanent_id=20170113013331393167295636071360687; __dd_token_id=20170113013334570919393827c486a5; permanent_key=20170113013334424301671049a98176;”
    ' * “login.dangdang.com=.AYH=2017011301333301337419125&.ASPXAUTH=; login.dangdang.com=.AYH=2017011301333301337419125&.ASPXAUTH=”
    ' * “95,22”
    ' * “95,22,119,26”
    ' * “jsonp1484242417110({"returnval":"0","type":1});” | “__permanent_id=20170113013331393167295636071360687; __dd_token_id=201701130133397551961197746349e7; permanent_key=20170113013334424301671049a98176; login.dangdang.com=.AYH=2017011301333301337419125&.ASPXAUTH=; login.dangdang.com=.AYH=2017011301333301337419125&.ASPXAUTH=”
    ' * “jsonp1484242417266({"returnval":{"error_code":0}})” | “USERNUM=/OSlf9/d6Q/bz+CuknOPGA==; login.dangdang.com=.AYH=2017011301333301337419125&.ASPXAUTH=PlXIXFp0ajZtRpTb2lq0lQehuXRb+agJWPtgZIo9bRcRy5UmW9B2BA==; dangdang.com=email=MTcwODExMDAwNTI1MzE5OUBkZG1vYmlscGhvbmVfX3VzZXIuY29t&nickname=&display_id=6318302932039&customerid=9bbbrO8huU4XxmfuqbsVgg==&viptype=mnjWzwvRVIQ=&show_name=170%2A%2A%2A%2A005253199; ddoy=email=1708110005253199%40ddmobilphone__user.com&nickname=&agree_date=1&validatedflag=0&uname=17081100052&utype=1&.ALFG=on&.ALTM=1484242420; sessionID=pc_9e6af993f6b4571b6250852161952474a8e6efe4c5fce996c937d1da8b9ddd7a; __dd_token_id=201701130133408138252474124fc2c4”
    ' 被调试易程序运行完毕
    
    .子程序 _验证码图片框_鼠标左键被按下, 逻辑型, , ' 本源码来自三叶资源网(www.sanye.cx)
    .参数 横向位置, 整数型
    .参数 纵向位置, 整数型
    .参数 功能键状态, 整数型
    
    点击次数 = 点击次数 + 1
    点击标签.标题 = “已点击倒字:” + 到文本 (点击次数) + “ 个”
    倒字验证码坐标 = 倒字验证码坐标 + 选择 (倒字验证码坐标 = “”, 到文本 (横向位置) + “,” + 到文本 (纵向位置), “,” + 到文本 (横向位置) + “,” + 到文本 (纵向位置))
    调试输出 (倒字验证码坐标)

    文件下载

    解压密码:
    下载地址

    本站大部分下载资源收集于网络,只做学习和交流使用,版权归原作者所有,若为付费资源,请在下载后24小时之内自觉删除,若作商业用途,请到原网站购买,由于未及时购买和付费发生的侵权行为,与本站无关。本站发布的内容若侵犯到您的权益,请联系本站删除,我们将及时处理!
    51分享吧 » 当当网登录cookie处理例子
    • 195会员总数(位)
    • 2014资源总数(个)
    • 0本周发布(个)
    • 0 今日发布(个)
    • 380稳定运行(天)

    51分享吧 51DZSC.COM

    开通VIP 超级项目
    升级SVIP尊享更多特权立即升级