最新公告
  • 欢迎您光临51分享吧,本站秉承服务宗旨 履行“站长”责任,销售只是起点 服务永无止境!立即加入我们
  • .版本 2
    .支持库 spec
    .支持库 dp1
    
    .子程序 _按钮1_被单击
    .局部变量 url, 文本型
    .局部变量 body, 文本型
    .局部变量 str, 文本型
    .局部变量 bin, 字节集
    .局部变量 cookies, 文本型
    .局部变量 setcookies, 文本型
    .局部变量 uuid, 文本型
    .局部变量 nloginpwd, 文本型
    .局部变量 script, 类_脚本组件
    .局部变量 _t, 文本型
    
    url = “https://passport.jd.com/new/login.aspx”
    str = 编码_Utf8到Ansi (网页_访问_对象 (url, , , cookies, setcookies))
    uuid = 文本_取出中间文本 (str, “name=#引号uuid#引号 value=#引号”, #引号)
    _t = “_” + 文本_取出中间文本 (cookies, “; _”, “=”)
    调试输出 (“uuid =” + uuid, “_t =” + _t)
    url = “https://passport.jd.com/uc/showAuthCode?r=” + 时间_取随机时间戳 () + “&version=2015”
    body = “loginName=” + 删首尾空 (编辑框1.内容)
    str = 编码_Utf8到Ansi (网页_访问_对象 (url, 1, body, cookies, setcookies, #XMLHttpRequest))
    调试输出 (str)
    .如果真 (寻找文本 (str, #verifycode_true, , 假) ≠ -1)
        url = “https://authcode.jd.com/verify/image?a=1&acid=” + uuid + “&uid=” + uuid + “&yys=” + 时间_取现行时间戳 ()
        bin = 网页_访问_对象 (url, , , cookies)
        图片框1.图片 = bin
        编辑框3.内容 = “”
        .循环判断首 ()
            程序_延时 (666)
            处理事件 ()
        .循环判断尾 (取文本长度 (编辑框3.内容) < 4)
    .如果真结束
    script.执行 (#getEntryptPwd)
    nloginpwd = script.运行 (“getEntryptPwd”, 删首尾空 (编辑框2.内容))
    调试输出 (“nloginpwd = ” + nloginpwd)
    url = “https://passport.jd.com/uc/loginService?uuid=” + uuid + “&&r=” + 时间_取随机时间戳 () + “&version=2015”
    body = “uuid=” + uuid + “&eid=” + 到大写 (文本_取随机字符 (90)) + “&fp=” + 取数据摘要 (到字节集 (时间_取现行时间戳 ())) + “&_t=” + _t + “&loginType=c&loginname=” + 删首尾空 (编辑框1.内容) + “&nloginpwd=” + 编码_URL编码 (nloginpwd, 真, 真) + “&chkRememberMe=&authcode=” + 编辑框3.内容
    str = 编码_Utf8到Ansi (网页_访问_对象 (url, 1, body, cookies, setcookies, #XMLHttpRequest))
    调试输出 (str)
    调试输出 (编码_usc2到ansi (str))
    .判断开始 (寻找文本 (str, “success” + #引号 + “:” + #引号 + “//www.jd.com”, , 假) ≠ -1)
        调试输出 (“登录成功”)
    .判断 (寻找文本 (str, “pwd” + #引号 + “:” + #引号 + “u8d26u6237u540du4e0eu5bc6u7801u4e0du5339u914duff0cu8bf7u91cdu65b0u8f93u5165”, , 假) ≠ -1)
        调试输出 (“账户名与密码不匹配,请重新输入”)
    .判断 (寻找文本 (str, “emptyAuthcode” + #引号 + “:” + #引号 + “u9a8cu8bc1u7801u4e0du6b63u786eu6216u9a8cu8bc1u7801u5df2u8fc7u671f”, , 假) ≠ -1)
        调试输出 (“验证码不正确或验证码已过期”)
    .默认
    
    .判断结束

    @E丶JavaScript

    文件下载

    解压密码:
    下载地址

    本站大部分下载资源收集于网络,只做学习和交流使用,版权归原作者所有,若为付费资源,请在下载后24小时之内自觉删除,若作商业用途,请到原网站购买,由于未及时购买和付费发生的侵权行为,与本站无关。本站发布的内容若侵犯到您的权益,请联系本站删除,我们将及时处理!
    51分享吧 » 京东登陆js例子源码

    常见问题FAQ

    免费下载或者VIP会员专享资源能否直接商用?
    本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
    提示下载完但解压或打开不了?
    最常见的情况是下载不完整: 可对比下载完压缩包的与网盘上的容量,若小于网盘提示的容量则是这个原因。这是浏览器下载的bug,建议用百度网盘软件或迅雷下载。若排除这种情况,可在对应资源底部留言,或 联络我们.。
    找不到素材资源介绍文章里的示例图片?
    对于PPT,KEY,Mockups,APP,网页模版等类型的素材,文章内用于介绍的图片通常并不包含在对应可供下载素材包内。这些相关商业图片需另外购买,且本站不负责(也没有办法)找到出处。 同样地一些字体文件也是这种情况,但部分素材会在素材包内有一份字体下载链接清单。
    • 135会员总数(位)
    • 1798资源总数(个)
    • 0本周发布(个)
    • 0 今日发布(个)
    • 207稳定运行(天)

    51分享吧 51DZSC.COM

    开通VIP 站长亲测