最新公告
  • 欢迎您光临51分享吧,本站秉承服务宗旨 履行“站长”责任,销售只是起点 服务永无止境!立即加入我们
  • HTMLayout自绘登录界面

    .版本 2
    
    .程序集 窗口程序集1
    .程序集变量 Hwnd, HL窗口
    .程序集变量 编辑框_Us, HL编辑框
    .程序集变量 编辑框_Pa, HL编辑框
    .程序集变量 User, 文本型
    .程序集变量 Pass, 文本型
    
    .子程序 __启动窗口_创建完毕
    
    Hwnd.绑定 (取窗口句柄 ())
    Hwnd.修改窗口扩展风格 (#窗口扩展_分层)
    Hwnd.载入文件 (取运行目录 () + “/Skin/login-box.htm”)
    User = “admin”
    Pass = “8888”
    Hwnd.事件_挂接元素事件 (&主窗口_特性事件, #筛选事件_特性事件)
    
    .子程序 主窗口_特性事件, 逻辑型
    .参数 参数_元素句柄, 整数型, , he
    .参数 参数_目标元素句柄, 整数型, , target
    .参数 参数_事件类型, 整数型, , type “特性事件_”开头常量
    .参数 参数_额外参数, 整数型, , reason 根据不同事件而定
    .局部变量 局部_元素, HL元素
    .局部变量 局部_属性, 文本型
    .局部变量 参数_ID, 文本型
    
    .如果真 (位与 (参数_事件类型, #事件阶段掩码_已处理) = #事件阶段掩码_已处理)
        参数_事件类型 = 位与 (参数_事件类型, 32767)
    .如果真结束
    .判断开始 (参数_事件类型 = #特性事件_编辑值已改变)
        局部_元素.置句柄 (参数_元素句柄)
        参数_ID = 局部_元素.取属性 (“id”)
        .如果真 (参数_ID = “user”)
            编辑框_Us.置句柄 (参数_元素句柄)
        .如果真结束
        .如果真 (参数_ID = “pass”)
            编辑框_Pa.置句柄 (参数_元素句柄)
        .如果真结束
    
    .默认
    
    .判断结束
    
    .判断开始 (参数_事件类型 = #特性事件_按钮被按下)
        局部_元素.置句柄 (参数_目标元素句柄)
        局部_属性 = 局部_元素.取文本 ()
        .如果真 (局部_属性 = “login”)
            .如果真 (编辑框_Us.取文本 () = “”)
                信息框 (“账号不能为空!”, #信息图标, )
                返回 (真)
            .如果真结束
            .如果真 (编辑框_Pa.取文本 () = “”)
                信息框 (“密码不能为空!”, #信息图标, )
                返回 (真)
            .如果真结束
    
            .如果 (编辑框_Us.取文本 () = User)
                .如果 (编辑框_Pa.取文本 () = Pass)
                    信息框 (“恭喜,登录成功!”, #信息图标, )
    
                .否则
                    信息框 (“密码错误!”, #信息图标, )
    
                .如果结束
    
            .否则
    
                信息框 (“账户不存在!”, #信息图标, )
    
            .如果结束
    
        .如果真结束
    
    .默认
    
    .判断结束
    返回 (真)

    @Blankness

    文件下载

    解压密码:
    下载地址

    本站大部分下载资源收集于网络,只做学习和交流使用,版权归原作者所有,若为付费资源,请在下载后24小时之内自觉删除,若作商业用途,请到原网站购买,由于未及时购买和付费发生的侵权行为,与本站无关。本站发布的内容若侵犯到您的权益,请联系本站删除,我们将及时处理!
    51分享吧 » HTMLayout自绘登录界面源码

    常见问题FAQ

    免费下载或者VIP会员专享资源能否直接商用?
    本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。更多说明请参考 VIP介绍。
    提示下载完但解压或打开不了?
    最常见的情况是下载不完整: 可对比下载完压缩包的与网盘上的容量,若小于网盘提示的容量则是这个原因。这是浏览器下载的bug,建议用百度网盘软件或迅雷下载。若排除这种情况,可在对应资源底部留言,或 联络我们.。
    找不到素材资源介绍文章里的示例图片?
    对于PPT,KEY,Mockups,APP,网页模版等类型的素材,文章内用于介绍的图片通常并不包含在对应可供下载素材包内。这些相关商业图片需另外购买,且本站不负责(也没有办法)找到出处。 同样地一些字体文件也是这种情况,但部分素材会在素材包内有一份字体下载链接清单。
    站壳网
    一个高级程序员模板开发平台
    • 122会员总数(位)
    • 1786资源总数(个)
    • 0本周发布(个)
    • 0 今日发布(个)
    • 183稳定运行(天)

    51分享吧 51DZSC.COM

    开通VIP 站长亲测