最新公告
  • 欢迎您光临51分享吧,本站秉承服务宗旨 履行“站长”责任,销售只是起点 服务永无止境!立即加入我们
  • 腾讯在线人数采集源码

    .版本 2
    
    .程序集 窗口程序集_启动窗口
    .程序集变量 正则, 正则表达式类
    .程序集变量 开奖时间, 文本型
    .程序集变量 SQL, 类_数据库
    .程序集变量 表名, 文本型
    .程序集变量 秒数, 整数型
    
    .子程序 __启动窗口_创建完毕
    
    时钟1.时钟周期 = 1000
    表名 = “txffcj”  ' sql数据库的表名
    秒数 = 取秒 (时间_取北京时间 ())
    
    .子程序 子程序_采集, 文本型
    .局部变量 请求地址, 文本型
    .局部变量 返回数据, 文本型
    
    请求地址 = “http://77tj.org/api/tencent/onlineim”
    返回数据 = 到文本 (网页_访问_对象 (请求地址, 0, , , , , , , , , , , , , , , , , ))
    正则.创建 (#正则, 返回数据, , , , )
    开奖时间 = 正则.取子匹配文本 (1, 1, )  ' 开奖时间
    返回 (正则.取子匹配文本 (1, 2, ))  ' 开奖号
    
    .子程序 _时钟1_周期事件
    .局部变量 在线人数, 文本型
    .局部变量 执行结果, 逻辑型
    
    秒数 = 秒数 + 1
    .如果真 (秒数 > 0 且 秒数 < 8)
        在线人数 = 子程序_采集 ()
        .如果 (编辑框1.内容 ≠ 在线人数 且 在线人数 ≠ “”)
            编辑框1.内容 = 在线人数
            执行结果 = SQL.方法_增加记录行 (表名, “shijian='” + 开奖时间 + “',renshu='” + 在线人数 + “',kaijianghao='” + 子程序_分离开奖号 (在线人数) + “'”)
            标签1.标题 = 开奖时间
        .否则
    
        .如果结束
    
    .如果真结束
    .如果真 (秒数 ≥ 60)
        秒数 = 取秒 (时间_取北京时间 ())
    .如果真结束
    
    
    .子程序 子程序_分离开奖号, 文本型
    .参数 在线人数, 文本型
    .局部变量 i, 整数型
    .局部变量 分离号码, 文本型, , "0"
    .局部变量 万位, 整数型
    
    文本_逐字分割 (在线人数, 分离号码)
    .计次循环首 (取数组成员数 (分离号码), i)
        万位 = 万位 + 到整数 (分离号码 [i])
    .计次循环尾 ()
    万位 = 万位 % 10
    返回 (到文本 (万位) + 分离号码 [6] + 分离号码 [7] + 分离号码 [8] + 分离号码 [9])

    @nb66666

    文件下载

    解压密码:
    下载地址

    本站大部分下载资源收集于网络,只做学习和交流使用,版权归原作者所有,若为付费资源,请在下载后24小时之内自觉删除,若作商业用途,请到原网站购买,由于未及时购买和付费发生的侵权行为,与本站无关。本站发布的内容若侵犯到您的权益,请联系本站删除,我们将及时处理!
    51分享吧 » 腾讯在线人数采集源码
    • 178会员总数(位)
    • 2014资源总数(个)
    • 0本周发布(个)
    • 0 今日发布(个)
    • 332稳定运行(天)

    51分享吧 51DZSC.COM

    开通VIP 超级项目
    升级SVIP尊享更多特权立即升级